Uploaded image for project: 'Repose'
  1. REP-5616

Upgrade Jetty to the latest minor version (9.4.x)

    Details

    • Type: Story
    • Status: Resolved (View workflow)
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 8.8.0.0
    • Component/s: None
    • Labels:
      None
    • Sprint:
      Sprint 156, Sprint 157
    • Story Points:
      5
    • Capitalizable:
      True

      Description

      Before we could add support for WebSockets and async processing, we need to upgrade to the latest version of Jetty.

      We should update to the latest Jetty minor version (9.4.x), but right now Repose doesn't even compile. They internally moved some packages around and deprecated some things in 9.3.x that are gone in 9.4.x.

      We suspect that the stuff we're using got moved (as opposed to removed).

      We'll need to figure out what's broken and how we're going to approach fixing it (i.e. which stories we need to work this).

      This will likely be figuring out how to fix each broken issue you run into.

      Acceptance Criteria:

      • Repose functional tests work with Repose using the latest minor Jetty version (9.4.x).

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                wdschei Bill Scheidegger
                Reporter:
                wdschei Bill Scheidegger
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: